I switched to CrunchBang (#!) today. The debian-based distro is fast and everything installed effortlessly. Except I didn’t like thunar, the default file manager. Some googling revealed that despite #! comes with thunar 1.2.3, the 1.6 version is available with lots of new features including tab support. After some messing around, here’s how I installed thunar 1.6.2.
Setup siduction keyring:
wget http://packages.siduction.org/base/pool/main/s/siduction-archive-keyring/siduction-archive-keyring_2013.03.29_all.deb
dpkg -i siduction-archive-keyring_2013.03.29_all.deb
rm siduction-archive-keyring_2013.03.29_all.deb
Add this line to /etc/apt/sources.list:
deb http://ftp.spline.de/pub/siduction/xfcenext unstable main
Add the following to /etc/apt/preferences:
Package: thunar libthunarx-2-0 thunar-data
Pin: origin ftp.spline.de
Pin-Priority: 1200
And finally,
sudo apt-get update
sudo apt-get install thunar
The new thunar looks much better. I might try this for a few days and consider moving to nautilus only as a last resort.
Comments
Thanks, installing was a breeze with this tutorial – logged out and back in after install and it worked perfectly. 1.6 is a huge improvement to me, having a tabbed file explorer that’s already the system default file handler is nice.
Yup, tabs FTW!
I did everything in the instructions except when I get to the last part it showed me this error, how do I download/install the required dependencies?
me@system:~$ sudo apt-get install thunar
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
thunar : Depends: libexo-1-0 (>= 0.10.0) but 0.6.2-5 is to be installed
Depends: libxfce4ui-1-0 (>= 4.9.0) but 4.8.1-1 is to be installed
Depends: thunar-data (= 1.6.2-1) but 1.2.3-5~crunchbang1 is to be installed
Recommends: xfce4-panel (>= 4.9.2) but 4.8.6-4 is to be installed
E: Unable to correct problems, you have held broken packages.
The latest version of thunar seems to have upgraded its requirements. You need to change your sources list to jessie from wheezy to pick them up but this may (or may not) have an impact on your CrunchBang installation.
Trackbacks
Download Tool
Upgrading to thunar 1.6.2 in crunchbang | Accidents Happen
Comments are closed.